Get in touch
Back
Maintenance

Test maintenance downtime

Completed 1 May at 04:36am AWST.

periculum.dgiglobal.com dgi-express.dgiglobal.com
Completed

Maintenance completed

Posted 1 May at 04:36am AWST.
Started

Server patching for the latest security upgrades may result in some very brief downtime.

Posted 1 May at 12:36am AWST.